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Respectfully dedicated to the memory of:

Francis R Scobee
Michael J Smith

Ellison S Onizuka
Judith A Resnick
Ronald E McNair

Gregory Jarvis
S Christa McAuliffe

the crew of Challenger flight STS 51-L, 28th January 1986
and to all who have lived - and died - for The Dream.

"Oh, I have slipped the surly bonds of earth,
And danced the skies on laughter-silvered wings;

Sunward I've climbed and joined the tumbling mirth
Of sun-split clouds -- and done a hundred things

You have not dreamed of -- wheeled and soared and swung
High in the sunlit silence. Hov'ring there,

I've chased the shouting wind along and flung
My eager craft through footless halls of air.

Up, up the long, delirious, burning blue
I've topped the wind-swept heights with easy grace,

Where never lark, or even eagle, flew;
And, while with silent, lifting mind I've trod
The high, untrespassed sanctity of space,

Put out my hand, and touched the face of God."

"High Flight"   John G Magee Jr, 1943
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1.  Introduction

SkyMap is a powerful "Planetarium" program for Microsoft Windows.  It will display a map of 
the sky as seen from any point on Earth for any date between 4000BC and 8000AD.  Once 
drawn, the user can get information about any object displayed on the map simply by pointing at 
the object with the mouse and clicking the button.  Two different types of map can be drawn - a 
"Horizon" map showing the observer's local horizon, and a "Sky Area" map showing a detailed 
view of a small area of the sky.

SkyMap can also display photographic images, supplied in the form of GIF or Windows bitmap 
files.  These can either be displayed manually, or associated with objects and displayed 
automatically.  Thousands of these images are freely available on bulletin board systems and 
commercial information systems such as CompuServe (tm).

Unlike other programs of its type which are on the market, SkyMap specifically doesn't claim to 
be blindingly fast.  What it does claim to be is one of the most accurate programs of its type.  It 
uses the most rigorous methods that I could find for all its calculations.  Examples of this are:

1.  The planetary positions computed by SkyMap will generally differ from those published in 
the "Astronomical Almanac" by less than half a second of arc.  (For comparison, the apparent 
diameter of Neptune, as seen from Earth, is about 2", whilst that of Jupiter varies between about 
30" and 45".).  

2.  Many astronomy programs currently available only compute geocentric planetary and lunar 
positions, making them effectively useless for such tasks as viewing eclipses and occultations.  
SkyMap rigorously computes topocentric coordinates - coordinates as seen from the actual 
location of the observer - thus allowing solar eclipses, for example, to be viewed.

3.  All star positions are rigorously reduced from mean to apparent place, with corrections for 
proper motion, precession, nutation, aberration, and refraction being computed.

All of these features have been designed to allow SkyMap to be used by the serious amateur or 
professional astronomer as well as by the novice, although the program is (I hope!) sufficiently 
"user friendly" for the novice to use just to answer questions like "what's that bright object up 
there?".

The program carries out its calculations in as efficient as manner as possible, but it never 
compromises precision for the sake of speed.  An increase in speed can always be achieved by 
using a faster computer!  Having said all that, the speed is still reasonable; on the author's 
33MHz 486-based PC for example, the horizon map, with default settings, is computed and 
drawn in about 5 seconds.
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Although I am releasing SkyMap as Shareware, I quite appreciate that you may not consider it 
worth paying any money for in its current form.  I would obviously like to be paid the 
registration fee - I've put a great deal of work into this software - but I would still appreciate 
receiving your feedback on the program even if you feel it's not currently worth registering.  If 
you do feel this way I'd like to know what, if anything, I could do to make you change your mind
in the future!

Whilst developing SkyMap I've received the help and encouragement of a number of people.  I'd 
especially like to thank David Webber for many useful suggestions and help with the 
mathematical problems I encountered, and Steve Moshier for generously consenting to allow me 
to use many of his coding ideas for various astronomical calculations.  Finally, I'd like to thank 
Jean Meeus for writing the book "Astronomical Algorithms" (Willman-Bell, 1991), without 
which this program would never have existed,
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2.  System Requirements

SkyMap requires Microsoft Windows version 3.1 or above to run.  It will not work with 
Windows 3.0 or earlier.

A maths coprocesser is not actually required to run SkyMap, but is definitely recommended.  
SkyMap does a great deal a great deal of trigonometry while creating maps, and use of a 
coprocessor can speed up this process by a factor of ten or more!

SkyMap will work with any type of display supported by Windows, but the best results will be 
achieved with VGA or better (SuperVGA, 8514/a, etc).  In order to show image files correctly, a 
display capable of showing 256 or more colours is recommended.

Maps can be printed on any type of printer supported by Windows.  The best results will be 
obtained from a laser printer, but perfectly acceptable results will be obtained from a 9-pin or 24-
pin dot-matrix printer, too.
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3.  Data Sources

The sources of the data used by SkyMap are as follows:

Stars

Smithsonian Astrophysical Observatory (SAO) star catalog,  (SAO Staff, 1966), 1990 machine 
readable version, as supplied on NASA's National Space Science Data Center's "Selected 
Astronomical Catalogs, Volume 1" CD-ROM.

The SAO star catalog is a catalog of 258,997 stars to epoch J2000.0, and is reasonably complete 
down to magnitude 9.5 or so.  The star database supplied with this version of SkyMap contains 
all the stars from the SAO catalog down to magnitude 7.0 - a total of 15,931 stars.  Larger 
databases, up to and including the full SAO catalog, will be supplied to registered users of this 
software on request. (The database derived from the full catalog is roughly 5.2MB in size.)

Planets and Sun

The positions of the Sun, and of the planets Mercury to Neptune are computed using a subset of  
Bretagnon and Francou's VSOP87 planetary theory, as described in the book "Astronomical 
Algorithms", by Jean Meeus (Willman-Bell, 1991).

Spot checks against recent editions of the "Astronomical Almanac" indicate that the mean error 
in the computed positions of the planets is under half a second of arc.

Moon

The position of the moon is computed from the ELP 2000-85 lunar theory (Chapront-Touzé and 
Chapront, 1988), which in turn is fitted to the DE200/LE200 numerical integration of the Jet 
Propulsion Laboratory (Standish, 1981).
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4.  Contacting the Author

I would prefer you to contact me by e-mail if you are able to.  I can be reached at any of the 
following addresses, in decreasing order of preference:

Internet: chris@chrism.demon.co.uk
BIX: cmarriott
CompuServe: 100113,1140

If you don't have access to e-mail on any of the above systems, or you'd like to become a 
registered used of this software (see below), my postal address is:

Chris Marriott
9, Severn Road
Culcheth
Cheshire WA3 5ED
United Kingdom

Please feel free to contact me - I'd love to receive any comments you may have on the program, 
or suggestions as to how it could be improved.
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5.  Registering SkyMap

I have put a tremendous amount of work into SkyMap.  If you use the program on a regular 
basis, and you find it useful, please show that you appreciate this effort by paying the modest 
registration fee, as follows:

UK Elsewhere
Personal Use £15 £20 or $40US
Club Use £25 £30 or $60US

Personal registration allows the program to be used by one person.  You may install the software 
on any number of computers, as long as only one will be in use at any one time.

Club registration allows free use by all members of an astronomy club (or, indeed, any other sort 
of club!), on any number of computers, whilst at club meetings.  Any club member who wants to 
use the program at home is still expected to register the program personally.

The reason I'm asking more from overseas users is simply to cover the additional cost to me of 
sending you the registration goodies by air-mail.

Now, read this next section carefully please - it's a bit complicated!

If you live in the UK, or have a UK postal address, you pay the "UK" fee.  Send either cash or a 
cheque made payable to "Chris Marriott" to the address above.

If you live overseas, you have two choices about how to pay the "Elsewhere" fee:

1.  Send me British currency, or a cheque in £ sterling drawn on a British bank, for the £ 
registration fee.

2.  Send me cash, either for the $US fee, or the equivalent amount in your local currency 
(provided it's something exchangable - no roubles, etc!).  The reason this amount is a bit more 
than the £ equivalent is because I have to pay a fee to change foreign currency.

I'm sorry, but I'm not able to handle credit cards.

Anyone who registers the program will receive from me:

1.  A personalized version of the program with your name in the "About" box, and your 
geographical location and time zone as the default observation location.  When you register the 
program, don't forget to tell me what these are, and what disk format (3.5" or 5.25") you'd like 
me to send you.
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2.  A larger version of the star database with a much fainter limiting magnitude.  With the 
registered version of the program I'll send you the largest star database that will fit, compressed, 
on a single disk of the format you've requested.  If you'd subsequently like an even larger one, 
tell me either what limiting magnitude you'd like, or how big a file you'd like, and I'll send it to 
you for a small fee, to cover the cost of the disks plus postage.  Remember though, the size of the
catalog shoots up fast with limiting magnitude!  The database containing all 258,997 stars in the 
SAO catalog is roughly 5.2 megabytes in size.

3.  A nice laser-printed version of the manual.

4.  The right to upgrade to any later version of SkyMap for a nominal fee.

5.  "Preferential" consideration of any suggestions you might have for enhancements to the 
program!

Please see the section of the manual entitiled "Contacting the Author" for details of where to 
send the registration fee to.
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6.  Installing SkyMap

SkyMap is distributed as two ZIP archive files - one containing the program and documentation; 
the other containing data and support files.

The program archive - SKYMAP12.ZIP - should contain the following files:

README.1ST Read this file!
HISTORY.TXT Release history of the program.
SKYMAP.EXE Main SkyMap program.
SKYMAP.HLP On-line help file.
SKYMAP.WRI This manual.

The data archive - SKYMAP1D.ZIP - should contain the following files:

README.2ND Read this file!
STAR.SKY Main star database.
STARNAME.SKY Star name database.
STARPROP.SKY Star proper name database.
CONFIGUR.SKY Constellation figures database.
CONNAME.SKY Constellation name database.
MOON.SKY Moon position database.
PLANETS.SKY Planet position database.
CTL3D.DLL 3D Control library.
MWSPIN.DLL Spin button control library.

You may also have one or more picture files.  Refer to the "Displaying Pictures" section of the 
manual for information about how to use these.

To install SkyMap, carry out the following steps:

1.  Create a directory on your hard disk.  For the purposes of this discussion, we'll assume this is 
directory C:\SKYMAP.

2.  Unpack both the archive files into the directory.

3.  Read the "Readme" text files.  They may contain important information not in the manual!

4.  Select the Program Manager group you'd like to add the SkyMap icon into.

5.  From the Program Manager's "File" menu, select "New...".  A dialog box will appear.  Select 
"Program Item" (this should be the default, anyway) and press the OK button.
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6.  The "Program Item Properties" dialog will appear.  Fill it in as shown below, then press the OK
button.

7.  The SkyMap icon (a picture of a telescope) should appear in the Program Manager.  SkyMap 
is now installed.
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7.  Configuring SkyMap and Displaying your First Map

When SkyMap is run for the first time, you must configure it for the your location.  Before 
SkyMap can correctly draw a map of the sky for you, you have to tell it where you are, and what 
time zone you are in.  To configure the program, carry out the following steps:

1.  Run SkyMap by double clicking on its icon in the Program Manager.  The empty SkyMap 
main window should appear, looking something like this:

The grey area at the bottom of the window is the "status bar", used to display information to the 
user.

2.  From the File menu, choose "New...".  A dialog box similar to the following will be displayed:

Press ENTER to select the default "Horizon Map" selection.  A blank horizon map window will be 
displayed, and the menu bar will change to the horizon map menu.  Note that the message "Press 
F5 to draw the map" has appeared on the status bar.  Ignore this message for the time being!

3.  From the "Options" menu, choose "Observer...".  The Observer dialog box will be displayed:

Fill in your longitude and latitude, each in degrees, minutes, and seconds.  You need not be exact 
- a position correct to the nearest degree is fine unless extreme accuracy is required.

In the "Local Time" box enter your time zone, expressed in minutes ahead or behind Universal 
Time (UT), commonly called Greenwich Mean Time (GMT).  Eg, if your time zone is Eastern 
Standard Time, you are 5 hours behind UT, so you would enter "300" (5x60) into the text box, 
and click the button to change the display to read "behind UT".

If Daylight Saving Time (called "Summer Time" in the UK) is currently in operation, check the 
appropriate box.  If it is not currently in force, leave the box blank.

Note that if you are using a registered version of the program, this dialog should already contain 
the correct information for you.  All you will have to change is the "Daylight saving time" check 
box.

4.  Finally, you should save the information you've entered.  From the "File" menu, choose "Save
Defaults...".  A box will appear asking you if you really want to save the information:
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Press the "Yes" button.  The information will be saved in a configuration file called SKYMAP.INI 
and will be used as the default values for all maps subsequently drawn.

5.  Press the F5 key.  A "Please wait" box will be displayed for a few seconds (depending on the 
speed of your computer), after which a map of the southern part of the sky as it currently looks 
from your location will appear in the map window.  If you maximize the map window, you 
should see something like this:

The actual map you will see will have a black background.  Colours have been reversed for ease 
of printing on the above map!

Note the following features of this map:

1.  Along the bottom of the map is the horizon, with the compass points displayed along it.  By 
default, the program displays a view of  roughly one third of the sky, centred on the southern 
horizon.  The zenith is at the top of the map.

2.  Stars are displayed as dots of differing sizes.  The brighter the star, the larger the dot.  By 
default, stars down to magnitude 5.0 are displayed, although the star database supplied with the 
program contains stars down to magnitude 7.0 (fainter for the registered version of the program).

3.  By default, constellation names and figures are displayed.  These can both be switched off 
using the items on the "View" menu.

4.  Planets are shown as dots, with the standard astronomical symbol alongside.  The planets 
Mercury, Saturn, Uranus and Neptune can be seen on the illustrated map.  The Moon (not visible 
on the above map) is displayed with its correct phase and orientation.  The Sun (visible in 
Aquarius on the illustration) is displayed as a hollow circle.

5.  The status bar at the bottom of the window displays information about the map, such as the 
time and date, and the coordinates of the map centre.
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8.  Drawing a Horizon Map

A horizon map shows the sky as seen from the observer's location for a particular time and date.  
It will probably be the starting point for most runs of the SkyMap program.  To draw a horizon 
map, the following steps should be followed:

1.  From the "File" menu, choose "New...".  A dialog box similar to the following will be 
displayed, showing the different types of window that can be opened:

Double click on the "Horizon Map" item, press the OK button, or simply press ENTER to create a 
new horizon map.  A blank horizon map window will appear and the menu bar will change to 
show the horizon map menu options.

2.  Use the items on the "Options" menu to set all the options required for the map.  These 
options are described below.  Once the options have been set, you can save them to be used as 
the defaults for all future maps by selecting the "Save Defaults..." option from the "File" menu.

3.  Press the F5 key to draw the map.  This process will take anything from a few seconds to (in 
extreme cases!) several minutes, depending on the speed of your computer, and the complexity 
of the map.

4.  When the map appears, you can zoom in or out on it, identify objects on it, or print it.  These 
options are described in the next section of the manual.

The items on the "Options" menu are as follows:

Viewpoint....

The Viewpoint option allows the user to specify which part of the sky appears on the map.  When
this option is selected, the following dialog is displayed:

The "Azimuth" and "Altitude" fields specify the coordinates of the centre of the map.  Azimuth is
simply the compass bearing and has the value 0° for North, 90° for East, 180° for South, and 
270° for West.  Altitude is 0° on the horizon, and 90° directly overhead.

The "Radius" field specifies the vertical size of the map.  The altitude range of the map will be 
from (Centre-Radius) to (Centre+Radius), and the azimuth range will scale accordingly.

Notes:

1.  Even if the radius is greater than the centre azimuth (ie, Centre-Radius<0), objects below the 
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horizon will not be displayed - the horizon line will simply appear higher up the map.

2.  To display a circular map of the whole sky, enter a centre altitude of 90°, and a radius of 90°.  
In this case the azimuth setting simply determines the orientation of the map - the specified 
azimuth will be appear at the bottom of the map.

Time....

The time and date of observation are initially set from the computer's clock for the instant that 
the horizon map window is created.  The Time option allows the user to display a map for any 
other time or date.  When this option is selected, the following dialog is displayed:

Fill in the dialog fields to the time and date required.  Pressing the "Now" button resets the time 
and date to that currently read from the machine's clock.

Notes:

1.  Dates before 1AD should be entered as negative numbers in the normal astronomical manner. 
Enter the year 1BC as "0", 1000BC as "-999", and so on.

2.  Dates must be between 4000BC and 8000AD, this being the range over which the program's 
calculations are valid.

3.  Dates on or after 0h on 15th October 1582 are assumed to be in the Gregorian calendar; dates 
before then in the Julian calendar.

4.  The observation time is assumed to be a local time - ie, the time as shown on an observer's 
clock.  The time zone information specified on the Observation Location dialog (see below) is 
used to convert the time to UT.

Observer....

The Observer option allows the user to enter information about the location from which the 
observation is taking place.  When this option is selected, the following dialog is displayed:

The "Latitude" and "Longitude" fields specify the location of the observer.  Both are entered in 
degrees, minutes, and seconds although, unless extreme accuracy is required, a position correct 
to the nearest degree will normally suffice.
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The "Conditions" information describes the atmospheric temperature and pressure at the time of 
observation.  This information is used when calculating the effects of refraction.  Changing these 
values only has a very small effect and, unless extreme accuracy is desired, they may safely be 
left at the default values.

The "Local Time" data specifies the time zone the observer is in.  It is used to convert the time of
observation (which is always assumed to be local time) into UT or GMT.  The time difference is 
entered in minutes (not hours!) difference between local time and UT.

The "Daylight saving time" box should be checked if DST (called "Summer Time" in the UK, 
and perhaps other countries too) is currently in operation.  If the box is checked, the local time is 
assumed to be one additional hour ahead of UT.

Stars....

The Stars option controls both which stars are plotted on the map, and the way that plotted stars 
are displayed.  When this option is selected, the following dialog is displayed:

The "Limiting magnitude of map" field determines the magnitude of the faintest star whose 
position will be calculated.  The higher the number, the fainter the stars which will be displayed 
(and the longer the map will take to compute).  The star database supplied with the program 
contains stars down to magnitude 7.0; the full SAO star catalog has stars down to magnitude 9.5 
or so.

The "Limiting magnitude displayed" field determines the magnitude of the faintest star that will 
actually be displayed on the map.  This can be used to temporarily omit the fainter stars on a 
map.  The value in this field must be less than or equal to the value in the previous field.

The lower half of the dialog box controls the way that the size of the star images varies with their
magnitude.  All stars brighter than the first "Display mag" field will be displayed using the size 
of star circle shown to its right.  All stars fainter than the second "Display mag" field will be 
displayed using the size of star circle shown to its right.  All stars with magnitudes between these
two limits will be drawn with an image size inversely proportional to the magnitude (ie, the 
lower the magnitude, the bigger the image).

The "Reduce to apparent position" check box allows the user to control whether or not star 
positions are rigorously reduced from "mean" to "apparent" place.  If the box is checked, the 
position of all stars is rigorously calculated, with corrections for precession, proper motion, 
nutation, and aberration being applied.  This is very accurate, and is essential when maps for the 
distant past or distant future are being drawn, but it does make the map slow to calculate.  If the 
box is left blank, these position reductions are not applied to the catalogue position of the stars, 
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which can have a dramatic effect on the speed with which a map is calculated.  Note that the 
effects of refraction are always calculated.  As a general "rule of thumb", it is safe to leave this 
box blank if a map is being drawn for a date between 1950 and 2050; the box should be checked 
if the date is outside this range.

Constellation Font....

This option allows the user to choose the font used for constellation names.  Selecting this option
displays a standard font selection dialog.

Labels

Selecting this option displays a submenu of labelling options.  If the "Altitude" option is 
selected, the following dialog is displayed:

The "Label type" radio buttons allow the type of altitude labelling to be selected.  The options 
are:

Automatic The label interval is selected automatically.
Every ... The label interval is specified in the text box.
Nothing No altitude labels are displayed.

If the "Draw Altitude Lines" box is checked, altitude lines are drawn across the map at the 
appropriate (manual or automatic) intervals, and the lines are labelled at the left-hand side of the 
map.

If the box is blank, altitude tick marks are drawn in the centre of the map.

Notes:

1.  If the "Nothing" box is selected, neither altitude lines nor labels are drawn, regardless of the 
state of the "Draw Altitude Lines" check box.

Selecting the "Azimuth" option from the "Labels" submenu displays the following dialog box:

The radio buttons in the "Label with" box control the type of azimuth labelling, and determine 
which (if any) of the other values in the dialog are used.

If the "Compass Points" button is selected, the horizon is labelled with the names of compass 
points, and the options in the "Compass Interval" section of the dialog are used.
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If the "Azimuth" button is selected, the horizon is labelled with azimuth numbers (in degrees), 
and the options in the "Azimuth Interval" section of the dialog are used.

If the "Nothing" button is selected, the azimuth axis is not labelled, and the rest of the dialog is 
ignored.

The "Compass Interval" section of the dialog determines the labelling method used when 
"Compass Point" labelling is selected.  The radio buttons allow the labelling interval to either be 
determined automatically, or one of three manual intervals selected.

The "Azimuth Interval" section of the dialog determines the labelling method used when 
"Azimuth" labelling is selected.  The options allow the labelling interval to be either determined 
automatically, or specified manually by the value in the text field.

If the "Draw Azimuth Lines" box is checked, lines are drawn up from the labelled points on the 
horizon to the top of the map.

Colours....

This option allows the user to select the colours used for every item drawn on the map.  When 
this option is selected, the following dialog is displayed:

To view or edit the colour of any map component, either double click on the name in the listbox, 
or move the listbox highlight to the name and press the "Edit..." button.  Either way, a standard 
colour selector box will be displayed, letting you choose the colour for the item.

Notes:

1.  Pressing the "Cancel" button will restore all the colours to their previous settings, not only the
colour just edited.

Draw

Selecting this option will draw the map, using the current option settings.  You may press the F5 
key as a "shortcut" for this option.
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9.  Using the Horizon Map

Once the horizon map has been created using the methods described in the previous chapter, it 
can be manipulated in various way.  This chapter describes the available options:

Setting the Visibility of Objects

The first section of the "View" menu contains a list of object names (stars, constellation names, 
etc), each of which has a tick alongside if that type of object is currently visible. Selecting any of
these options will toggle the visibility of that type of object, and the map will be redisplayed.

Changing the map scale

The "Zoom In" and "Zoom Out" items on the "View" menu may be used to change the 
magnification of the map.  The F2 and F3 function keys are shortcuts for these operations.  When
the map is first drawn, it is scaled so that the map exactly fills a maximized map window.  Every 
time "Zoom In" is selected, the size of the map increases by 50%, and the map is redrawn.  Every
time "Zoom Out" is selected, the size is correspondingly reduced.

When the map is zoomed, the centre of the current window will remain stationary.  You can 
therefore zoom in a particular feature by first scrolling it to the centre of the window, then 
repeatedly pressing the F2 key.  To aid this process, a shortcut method has been provided to bring
a point to the centre:

1.  Position the mouse pointer over the point on the map you would like to bring to the centre.

2.  Press the right mouse button.  A pop-up menu will appear at the mouse position, containing a 
number of items.  The exact number of items on the menu will depend on where the mouse is 
located.

3.  Select the "Centre" item with the left mouse button.  The window will scroll to bring the 
chosen point to the centre of the map.

Note that the map will not scroll past its edges (the boundaries of the full-screen normal size 
map).  In order to bring a point to the centre of the map it may, therefore, be necessary to zoom 
in one or more times first.

Identifying Objects on the Map
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To display a dialog box showing information about any star or planet on the map, move the 
mouse pointer over the star or planet, and press the right mouse button.  A pop-up menu will 
appear.  Select either "Identify Star" or "About <planet name>" as appropriate.

If, for example, you ask for information about Rigel - the bright star at the bottom right of Orion,
the following dialog is displayed:

The exact information displayed will obviously depend on the star, but note the following:

1.  The star's SAO catalog number is displayed in the dialog box title.  The SAO number is the 
way that SkyMap identifies the star internally - all other information is derived from this.

2.  The top section of the dialog displays the identify of the star.  The same star can be identified 
in a truly bewildering variety of different ways.  SkyMap attempts to show a few of the more 
popular names for the star:

The first line of the dialog always displays the name of the constellation that the star is in.  In the 
case of a star (such as this one) which has either a Bayer letter or Flamsteed number, the star's 
constellation is actually stored in the database.  In cases where this information is not present, the
constellation is computed from the star's location, using the official IAU constellation 
boundaries.

The next line, if present, displays the "proper name" of the star - Rigel, in this case.  Note that 
many star names are derived from Arabic and, as such, have a number of alternate English 
spellings.  In the case of such stars, the name that SkyMap displays may well be slightly different
from the name your reference sources show.  All that means is that I used a different reference 
book!

Next are shown the star's Bayer letter (b Orionis) and Flamsteed number (19 Orionis), if present.

Finally in the initial section of the dialog, the star's visual magnitude is shown.

3.  The lower section of the dialog shows the position of the star in several different coordinate 
systems.

First, the star's apparent geocentric right ascension and declination are displayed.  These 
coordinates are referred to the true equinox and ecliptic of date.  SkyMap applies the following 
corrections to the catalog position of a star:

Proper Motion
Annual Aberration
Precession
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Nutation

The star's position is also corrected for refraction before being displayed on the map, but the 
apparent position displayed in the dialog box does not include this correction.

Next, the star's catalog position is displayed - the right ascension (RA) and declination for the 
mean equinox and ecliptic of epoch J2000.0.  This information is taken straight from the SAO 
star catalog and contains no position corrections.

Finally, the current altitude and azimuth as seen from the observer's location are displayed.  The 
altitude displayed here includes the effects of refraction.

If information about a planet is requested, a more complex dialog with multiple screens of 
information is displayed.  For example, requesting information about Mars initially displays the 
following dialog:

The buttons on the right side of the dialog are used to select the different screens - the "Earth" 
(geocentric) data screen is displayed initially.  The names "Local",  "Earth", and "Sun" refer to 
the position of the viewer, eg, the "Sun" button displays heliocentric information.

The "Local" displays information about the planet as seen from the observer's location at the 
current time (for which the map is displayed).  The following information is displayed:

1.  The altitude and azimuth of the planet as seen from the observer's location at the current time.
This is derived from the apparent geocentric position, with additional corrections being applied 
for diurnal parallax (the difference between the position of the planet as seen from the centre of 
the Earth and the position as seen from the observer's actual position) and refraction.

The "Earth" screen (initially displayed) displays information about the planet as seen from the 
centre of the earth - ie, geocentric information.  The following information is displayed:

1.  The apparent geocentric right ascension and declination, referred to the true equinox and 
ecliptic of date.  This position is corrected for the effects of:

Light Time
Light Deflection (due to the Sun's gravity)
Annual Aberration
Nutation
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The position of the planet as displayed on the map has additional corrections for diurnal parallax 
and refraction, but these corrections are not reflected in the position displayed here.

2.  The constellation the planet is in.

3.  The true (geometric) distance of the planet in both astronomical units (exactly) and millions 
of km (approximately).  In the case of the Moon, the exact distance is displayed in km.

The "Sun" screen displays information about the planet as seen from the centre of the Sun - ie, 
heliocentric data.  The following information is displayed:

1.  The apparent ecliptic longitude and latitude of the planet, referred to the true ecliptic of date.

2.  The geometric radius vector of the planet (ie, the distance between the planet and the Sun) in 
both astronomical units (exactly) and millions of km (approximately).

The "Physical" screen displays physical information about the planet.  The following information
is displayed:

1.  The visual magnitude.

2.  The phase, as a fraction between 0 and 1.  A phase of 0 indicates that the object is "new"; a 
phase of 1 is "full".  The phase is equal to the fraction of the planet's disk that is illuminated, as 
seen from from the Earth.

3.  The apparent diameter, in seconds of arc.  For some planets, separate equatorial and polar 
diameters are shown.

4.  The phase angle, in degrees.  This is the angle between the Earth and Sun, as seen from the 
centre of the planet, and determines the phase of the planet as seen from the Earth.

5.  The elongation, in degrees.  This is the angle between the planet and the Sun, as seen from the
centre of the Earth.

6.  The light time in hours, minutes, and seconds.  This is the time taken for light to travel from 
the planet to the observer, and is an indication of the "age" of the view we see of the planet.  Eg, 
if the light travel time for Mars is shown as 5 minutes, this means that we are seeing Mars as it 
actually was 5 minutes ago.

Zooming to an Area Map
23



SkyMap 1.2

If you wish to display a detailed "Area Map" of a particular region of the sky, position the mouse
pointer over the point on the horizon map that you wish to be the centre of the area map.  Press 
the right mouse button and select "Area Map..." from the pop-up menu.  The following dialog 
box will appear:

Enter the radius of the map you would like, in degrees, then press ENTER.  A blank area map 
window will appear.  The next chapter of the manual describes how to draw and use the area 
map.

Printing the Map

To print the map, choose the "Print" option from the "File" menu.  This will display a standard 
"Print" dialog, allowing you to select the print options (printer, resolution, etc) in the usual way.

Notes:

1.  By default, the map is printed in landscape orientation.  If you wish to change this, use the 
"Print Setup" option.

2.  Currently, the map is always printed at the normal 100% zoom factor, no matter what the 
level of "zoom" on the screen currently is.  This issue will be addressed in a future release of 
SkyMap.

3.  The map is printed in black and white, using black symbols on a white background.  Options 
for printing maps in colour will be added in a future release of SkyMap.
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10.  Drawing a Sky Area Map

A Sky Area map shows a detailed view of a (normally) small area of the sky, centred on a 
particular point of right ascension and declination.  It is a circular map, displaying all objects 
within a specified radius of the centre.  There are two ways to draw a Sky Area map:

1.  Draw a horizon map, then click the right mouse button over the location you want to be the 
centre of the area map.  Select "Area Map..." from the pop-up menu which appears.

2.  From the "File" menu, select "New...".  The following dialog box will appear:

Double click on the "Sky Area Map" line in the list box, or move the list box selection to that 
line and press ENTER.

Whichever of these two methods is used, a dialog box similar to the following will be displayed:

The "Vertical Radius" field specifies the radius of the map, in degrees.  This must be between 1° 
and 90°.  The "Right Ascension" and "Declination" fields specify the coordinates of the map 
centre.  If you are drawing the Area map from a Horizon map, these will already contain the 
correct values.

When the dialog is correctly filled in, press OK to create a new map, or Cancel to abort the 
operation.  If you press OK, a blank Sky Area map window will be displayed, and the menu will 
change to the Sky Area menu.

Use the items on the "Options" menu to set all the options required for the map.  These options 
are described below.  Once the options have been set, you can save them to be used as the 
defaults for all future Sky Area maps by selecting the "Save Defaults..." option from the "File" 
menu.

Finally, press the F5 key to draw the map.  This process will take anything from a few seconds to
(in extreme cases!) several minutes, depending on the speed of your computer, and the 
complexity of the map.

The items on the "Options" menu are as follows:

Viewpoint...

This option displays the dialog box shown above, allowing the region of the sky displayed on the
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map to be altered.

Time...

This option is used to set the time and date of the observation, exactly as for the Horizon map.  
Note that although the map is at a fixed position on the RA/Dec coordinate grid, altering the time
and date will determine which planets are visible in the field of view, and is also used to compute
the effects of precession and proper motion on star positions, for example.

Observer...

This option displays a dialog box allowing the location of the observer to be set, exactly as for 
the Horizon map.  In the case of the Sky Area map, the most important thing this information is 
used for is in determining the apparent position of nearby objects such as the Moon, against the 
background of stars.

Stars...

This option displays a dialog box allowing the limiting magnitude and image size of stars to be 
specified, once more exactly as for the Horizon map.  Note that in the case of a Sky Area map 
drawn for a small region of the sky with a faint (high) limiting magnitude, switching off the 
"Reduce to apparent place" check box can have a huge impact on the time taken to compute star 
positions.  Once again, it is normally safe to neglect the effects of position corrections for maps 
drawn for dates between about 1950 and 2050, but not for maps outside this range.

Stars Labels...

Selecting this option displays the following dialog box, allowing the way that stars are labelled 
on the Sky Area map to be controlled:

The same star can, and often does, have more than one name.  The upper section of the dialog 
determines which, if any, of these names will be displayed, and is in decreasing order of 
precidence from top to bottom.  If, for example, both the "Proper Names" and "Bayer Letters" 
boxes are checked, a star will be labelled with its proper name if it has one, and its Bayer letter if
it doesn't have a proper name but does have a Bayer letter.

The lower section of the dialog determines which stars will be labelled.  If "All Stars" is selected,
all stars on the map which have the requisite name information will be labelled.  If "Down to 
magnitude" is selected, all stars brighter than the specified magnitude will be labelled.  If "None"
is selected, the upper section of the dialog is ignored, and no star labels will be displayed.

Constellation Names...
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This option displays a standard font selector allowing the user to select the font used to write 
constellation names on the map.

Colours...

This option displays a dialog box allowing the user to select the colour of the various 
components of the Area map.  It is used in exactly the same way as the corresponding dialog for 
the Horizon map.
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11.  Using the Sky Area Map

Once the Sky Area map has been drawn, it can be manipulated in various ways.  Most of the 
options are the same as for the Horizon map, so they are just summarized here for ease of 
reference.

Setting the Visibility of Objects

The top section of the "View" menu consists of a list of "toggles" controlling the visibility of 
various items on the Area map.  If an item has a tick mark alongside it, it is currently visible on 
the map.  If it does not have a tick mark, it is not visible.  The items are:

Stars
Planets
Constellation figures
Constellation Names
Right ascension/Declination Grid

Changing the map scale

The "Zoom In" and "Zoom Out" items on the "View" menu may be used to change the 
magnification of the map.  The F2 and F3 function keys are shortcuts for these operations.  These
options operate exactly as they do for the Horizon map.

Identifying Objects on the Map

To display a dialog box showing information about any star or planet on the map, move the 
mouse pointer over the star or planet, and press the right mouse button.  A pop-up menu will 
appear.  Select either "Identify Star" or "About <planet name>" as appropriate.  The information 
displayed is the same as for the Horizon map.

Zooming to an Area Map

To display a new Area map centred on a particular point on the current map, position the mouse 
pointer over the equired point and press the right mouse button.  Select "Area Map..." from the 
pop-up menu.
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Printing the Map

To print the map, choose the "Print" option from the "File" menu.  This will display a standard 
"Print" dialog, allowing you to select the print options (printer, resolution, etc) in the usual way.

29



SkyMap 1.2

12.  Displaying Pictures

One of the most exciting features of SkyMap is its ability to display photographic images of 
astronomical objects.  You can build up your own collection of pictures which can really bring 
the sky to "life", and which are a superb way to show astronomical objects to a novice on a 
cloudy night!

In order to display pictures, you should have a "SuperVGA" display capable of displaying 256 or
more colours.  You can display pictures on a standard 16-colour VGA display, but the results will
probably be pretty horrible!

Picture Formats

Skymap can currently display the following picture formats:

1.  GIF files.  GIF is probably the most popular of all image formats currently in use.  The format
was specifically devised to enable pictures to be easily transferred between different types of 
computer, and there are literally tens of thousands on pictures in GIF format available.  SkyMap 
will display files in either GIF87a or GIF89a format, and can handle both interlaced and non-
interlaced images.  The only restriction is that only the first image in a file can currently be 
displayed.  GIF files for the PC normally have an extension of ".GIF".

2.  Windows "Bitmap" files.  These are "device independent bitmap" files created for use with 
Microsoft Windows.  They normally have an extension of ".BMP" (for uncompressed images) or 
".RLE" (for compressed images).  An increasing number of these files can be found on bulletin 
board systems, normally made available for use as Windows "wallpaper".

Displaying Pictures Manually

From the "File" menu, choose the "Open Image..." item.  A standard file selector will be 
displayed, letting you select a file from any available drive or directory.  Pressing the OK button 
will display the picture in a window.

Displaying Pictures Automatically

SkyMap has the ability to load and display pictures of certain objects automatically.  At the 
moment, this capability is limited to the planets, Moon, and Sun, but will be extended in future 
versions of the program.  In order to use this feature of the program, carrry out the following 
steps:
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1.  Find a nice picture of a planet in any supported image format.  You can use the "manual" 
method described above to look through pictures until you find one you would like to have as a 
"standard" picture for a particular object.

2.  Copy the file to the directory containing the SkyMap program, and rename the file to 
"PLANET.EXT", where "PLANET" is the name of the planet, and ".EXT" is the "standard" extension
for the image format - ".GIF" for GIF files and ".BMP" for bitmap files.  For example, a GIF file 
you would like to use as your standard picture of Saturn should be renamed to "SATURN.GIF", 
and copied to the SkyMap directory.

3.  Now, if you draw a map and click the right mouse button over a planet, you should find that a 
"Picture of <Planet>" item appears on the resulting pop-up menu.  Selecting this item will 
display the picture in a new window.

Notes:

1.  When you click on a planet, SkyMap will first of all look for a file with a ".GIF" extension, 
and then for a file with a ".BMP" extension.  If files with both extensions are present, the GIF file 
will be displayed.
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